View the latest post [Novalia 2021] Office Party

Thu Dec 16, 2021 5:33 pm


The office is having a super fun party to celebrate Novalia! Be sure to stop by some of the events that reception has set up for you:

Submit an ugly or festive sweater design, for the chance to win gre [...]

[ Read all ]

Random Winner



View the latest post Fun with SSL certificates! 11-28 to 11-29

Sun Nov 29, 2020 11:37 am

You probably noticed an invalid SSL certificate error starting Saturday morning that prevented you from accessing Windlyn. The problem was our certificate did not expire. We went ahead and renewed our SSL certificate (multiple times!) and we'd still get the error.

We grinded away at this for 14 hours, configuring and reconfiguring anything I could think of being in the chain that makes it all work, adding and deleting certificates, trying new SSL requesting apps, reconfiguring network port forwarding devices, testing and more testing, restoring from backups--the whole enchilada... and still the same problem.

It wasn't until very early this morning that I ran across someone on the googles that had the same problem, but the solution was a hardware reset. Unfortunately, that required someone at the datacenter to physically do the job. So it wasn't until this morning (Sunday) that I was able to get someone down there to help. And boom, reset and it allowed me to reconfigure our gateway and it was working! Now that all lay ahead was reconfiguring our servers back to the way they were--and get new certificates installed. :worry:

tldr; The combination of a couple of pieces of network hardware and devices commandeered port 443 (the SSL port) for remote access and would intercept any calls for SSL connections--causing the certificate mismatch. Changes to routing would not be accepted--and only a factory reset that required a physically doing it enabled access again.

[ Back ]